Cannot open COM port for FiPy and PyTrack

  • Hi there,

    I was trying out the PyTrack on Win7 and installed the driver as per the instructions given in the docs. I even updated the firmware on the PyTrack successfully.

    If I connect the PyTrack as a standalone without any module, I can see the COM port open. However, as soon as I connect my FiPy or GPy the COM port disappears for my PyTrack.

    I believe this is an open topic still:

    Did anyone solve this issue yet?


  • This post is deleted!

  • @combaindeft
    B) is clear, since the 3.3 regulator is on the FiPy device. Without that, no power at the 3.3V pin.
    Due to A) with the rock solid supply through a battery it is hard to accept, that it's a firmware issue, at least of the FiPy. Still, the PyTrack board can be the culprit. Did you try to run the FiPy without the PyTrack board, like on a breadboard with a separate USB/serial interface?

    Shorting 3.3 and GND should be avoided.
    P.S.: It's a pity that Pycom does not publish schematics.

  • @nathanh


    A) FiPy+PyTrack+LiPo-Battery (Not-Attached-to-USB3.0)
Vin = 4.09~4.10 V
    3V3 = 3.32 V

    B) PyTrack+USB-Serial-device (Attached-to—USB3.0)

    • same port as A)

      Vin = 4.85 V
      3V3 = 0.23 V

    C) PyTrack+USB-Serial-device (Attached-to—USB3.0) + Hotswap-in-FiPy

    • same port as A) & B)

      Vin = 4.55 V
      3V3 = 3.32 V

    D) PyTrack+FiPy+NO-USB-Serial-device (Attached-to—USB3.0)

    • same port as A) & B) & C)
    • same combo as C)
    • Just unplugged USB from PyTrack, and re-attached it…

      Vin = 1.69~2.51 V
      3V3 = 1.15~1.91 V

    - Also, worth nothing is that if my hand slips with the measuring probes, I get it to “boot-up” by accidentally shorting GROUND & 3V3, and I get a USB-Serial-Devices on my computer [ergo like A), B) & C) …] …
    - And then, I get the same Vin & 3V3 as C)
    - Which makes me conclude that you’ve guys have a Firmware issue!!! … and not a “bad usb-cable” or “bad usb-port” … etc etc.
    - For some reason, in the boot-sequence of the PyTrack Firmware, it choose not to boot-up FiPy and enable USB-Serial …
    - And, again, it’s odd that I can short GROUND & 3V3 with my measuring probes, and then it boots up FiPy and enables USB-Serial…

  • @combaindeft said in Cannot open COM port for FiPy and PyTrack:


    The logic that I can 1st boot up the PyTrack ... get a usb-serial port ... then I hot-swap in the FiPy ... the FiPy boots up ... means there is enough voltage / current for it to boot up ...

    Why the issue dissapears when I attach the LiPo Battery, and get a usb-serial (too) is key.

    Actually what @robert-hh is saying lines up rather than your logic. Booting 2 devices together at the same time will have a much higher current spike on boot up rather than powering one device then the next as after the initial boot current draw will drop. Also a lipo battery can supply more current than a standard usb port. For instance most 3g/ lte modems spike above 500ma on send and can fail when using a usb port on their own.

    Again you could be right and it's not an issue but the symptoms you're seeing with the fix you have point towards a current or voltage issue.

  • @robert-hh

    The logic that I can 1st boot up the PyTrack ... get a usb-serial port ... then I hot-swap in the FiPy ... the FiPy boots up ... means there is enough voltage / current for it to boot up ...

    Why the issue dissapears when I attach the LiPo Battery, and get a usb-serial (too) is key.

    As, I also get a usb-serial if only I boot up the PyTrack (just the PyTrack) ...

    I'm very much leaning toward a firmware issue ... in the boot sequence of the PyTrack when it checks how it wants to boot up .... in DFU-mode or USB-Serial mode ...

    As we've just proven that it boots up with USB-Serial in two Combo's ... but not in the 3rd ...

    PS ... also, I've changed multiple usb-cables, Ports and even other Mac computers ... still the same issue. And also, yeah, it's USB3.0 ports I've tried it on...

  • @combaindeft For me it still looks like a power supply problem, especially since attaching a LiPoy battery helps. If you did not do that yet, try another short & good USB cable and/or a different USB port on your computer, preferably a USB3 port.
    The power drops could be transitional. The current consumption of the devices vary a lot.
    Still it could be problem in the PyTrack board.

  • @robert-hh

    regarding it beeing a voltage issue.

    as I wrote below, if I 1st boot up the PyTrack ... then I hot-swap the FiPy into the PyTrack ... it works ...

    and when I do a:
    print (py.read_battery_voltage())

    I get the same reading of 4.45 --> 4.46 Volts.

    I re-do the same experiment, with the FiPy+PyTrack+JST-LiPo-Battery combo ... this time around it boot with usb-serial and the FiPy boots up (too).

    The readings I get then is: 4.43 --> 4.47

    So there is no issue with voltage and such ... and the devices don't use that much Amps either ...

    According to "System" the PyTrack is using:

    Current Available (mA): 500
    Current Required (mA): 500

    And it uses the same amount no matter what combo (Pytrack, PyTrack+FiPy or PyTrack+FiPy+Lipo-Battery ...)

    IMHO, there is no "Power issue" ... but rather a Firmware code (pytrack_0.0.8.dfu) issue ...

  • @seb

    I've had the same issue, and as I wrote in:

    The only way I can get it work is:

    1st) Connect only the PyTrack to usb
    2nd) I get a usb-serial device
    3rd) I then plug the FiPy device into the PyTrack ...
    4th) Now I see the FiPy boot up and run the "pycom.heartbeat(True)" ... Led blinking blue ...

    To re-cap, if I try to power on the FiPy+Track (combo) via usb, it doesn't even boot up (no Led blinking blue) ...

    I also just tried it with a JST LiPo Battery (FiPy+PyTrack+Lipo-Battery combo) ... and now it boots up and I get a usb-serial...

    So the odd thing is, why does it try to boot-up in DFU-mode when FiPy+PyTrack is connected?

    But it boots as usb-serial-device when only the Pytrack is connected? or when adding a battery, FiPy+PyTrack+Battery ...

    I find this a little bit of strange logic ... and It's a little bit odd ... and I do think there is some sort of issue in the Firmware code (pytrack_0.0.8.dfu)

    Where might one find the Firmware code (pytrack_0.0.8.dfu)? ... so one might have an investigative look at boot sequence of the PyTrack :-)

  • @sat That does not look well. Vin and 3.3V should get static readings of >4.5 V and 3.3 V. Looks like you have a power supply problem. Change the cable and/or the USB port of your computer.

  • @robert-hh @seb

    Sorry for the bullet 3: I had measured the voltage of pytrack without connecting FiPy. If I connect FiPy, 3v3 fluctuates between 1 volt and 2.1 volt and Vin fluctuates between 0.5 and 1 volt. I measured if using a simple multimeter. I do have access to a benchtop multimeter if you need to see the waveform over time. Let me know.

    Any help will be highly appreciated. Thanks.

  • @sat About bullet 3. : Are you sure you placed your board with the right orientation into Pytrack?

  • @seb Thank you for your response.

    1. I tried using a different USB cable. No luck.

    2. I can see it is returning what I am typing.

    3. The voltage in 3v3 is 0.162 volts and 5V pin is 4.7 volts.

    Note: When I try connecting the PyTrack with the FiPy module, Win7 tries to install drivers and fails. Do you think it is a drivers issue rather than a hardware fault?

    Thank you.

  • Hi,

    Let's try a few troubleshooting steps

    1. Can you try a different USB cable? We have had quite a few reports of some USB cables having issues with the GPy and FiPy

    2. If this doesn't make a difference, can you try connecting the RX and TX of the Pytrack together (2nd and 3rd pins on the left hand side). Then open the COM port and see if whatever you type in returned back to you

    3. If you have access to a voltmeter, could you measure the voltage on the Vin and 3v3 pins of your modules when it is plugged in

  • @seb Sadly I do not have any other module apart from GPy and FiPy. However, I do have a PySense and my GPy and FiPy works perfectly fine with PySense. That probably narrows it down to PyTrack. Any ideas?

  • Do you have any other Pycom modules you could test the Pytrack with? This way we could narrow down if the issue is caused by the FiPy/GPy or if it lies with the Pytrack

Pycom on Twitter