Firmware update after flash read err, 1000



  • Hi all,

    I was trying to upload my LoPy to the latest firmware when something went wrong and now I get this over the serial console

    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    flash read err, 1000
    Falling back to built-in command interpreter.
    OK
    >ets Jun  8 2016 00:22:57
    

    So first I tried to follow the instructions in here. But, apparently that tool is not available anymore...

    So I followed the instruction of a similar post and after debbuging I spotted the problem the next command times out:

    ./bin/updater.py --port "${serial_port}" --speed ${speed} wmac
    

    UNLESS, I do a reboot while I run the command in that case, it works (that is crazy):

    [javier@archy]  $ ./bin/updater.py --port /dev/ttyUSB0 --speed 115200 wmac
    Exception: Failed to connect to ESP32: Timed out waiting for packet header, on line 351
    [javier@archy] $ ./bin/updater.py --port /dev/ttyUSB0 --speed 115200 wmac
    WMAC=240AC40262AC
    

    So I run the command line update tool and pressed reset twice, once for getting the WMAC and another for getting the SMAC. Then the upgrade tool downloads the firmware and tries to upload to the board. Reading the code I spotted the line in which my the program hangs for me, it is under do_update function:

    ./bin/updater.py -c --port "${serial_port}" --speed ${speed} --tar "${FILE}" flash > ${TEMP_FILE} 2>&1 
    

    I printed the output and for me looks like it when it is run:

    ./bin/updater.py -c --port /dev/ttyUSB0 --speed 115200 --tar /tmp/tmp.foxHbzzN9v/update.tar.gz flash > /tmp/tmp.foxHbzzN9v/tmpfile 2>&1
    ./bin/updater.py -c --port /dev/ttyUSB0 --speed 921600 --tar /tmp/tmp.BgPUA1FKMt/update.tar.gz flash > /tmp/tmp.BgPUA1FKMt/tmpfile 2>&1
    

    You can see 2 lines cause I tried to run it with different UART speeds as I saw in other post that the speed was an issue too.

    In that step I am stuck. How can I get my LoPy work again?

    Regards,

    Javier



  • @Xykon , it is now the second time you save my day :))
    Successfully updated! You can mark this as solved!

    Just wanted to point that the command tool didn't work this time, but the python did. Anyway, next step try to connect it to my LoRa AP! Thank you for your help.

    Regards,

    (I was using a expansion board)


  • administrators

    @jvgd I have released an updated version, can you please try again?

    https://software.pycom.io/downloads/pycom_firmware_update_1.10.1.b3.tar.gz

    Are you using an Expansion Board 2.0 or a Pytrack / Pysense?



  • @seb for sure, I first tried to use the GUI tool, but seeing it wasn't working I switched to the command line where I have more control.

    The GUI tool connected to the board, let me select a country and it gets frozen in the Result page without showing anything, just the title.



  • Have you tried connecting 'P2' and 'GND' and reseting the board to put it into download mode and then just using the regular GUI update tool?



Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.