Pytrack firmware update fails

  • I get a "dfu-util: Lost device after RESET?" after initiating "dfu-util --device 05ac:8bcd -D ./pytrack_0.0.8.dfu".
    I am running Mac OS X, brewing the dfu-utils. The update of a wipy 2 with an Extension Board was successful.
    Any idea?

    The full output is:
    dfu-util 0.9

    Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
    Copyright 2010-2016 Tormod Volden and Stefan Schmidt
    This program is Free Software and has ABSOLUTELY NO WARRANTY
    Please report bugs to

    Deducing device DFU version from functional descriptor length
    Opening DFU capable USB device...
    ID 05ac:8bcd
    Run-time device DFU version 0100
    Claiming USB DFU Runtime Interface...
    Determining device status: state = appIDLE, status = 0
    Device really in Runtime Mode, send DFU detach request...
    Resetting USB...
    Deducing device DFU version from functional descriptor length
    dfu-util: Lost device after RESET?

  • @buw I'm surprised that made a difference, I have nearly always upgraded Pysense boards with a module on. But whatever works for you!

  • @seb: Thanks a lot! This time, the update process did not throw any error message. My fault was that I did not remove the **Py board.

  • The method I've found works best for me is as follows:

    1. Disconnect the board from USB and remove the **Py board
    2. prepare the dfu command in your terminal but don't press enter
    3. Press and hold the button on the Pysense/Pytrack
    4. Insert the USB
    5. wait a couple seconds
    6. run the dfu command

    You may need to try the above process a couple times to get it work, but this always seems to work the best for me.

  • Thanks jcaron for confirming this. I was not really aware of this but operated as you proposed. So I am still not successful.
    Just to note: In the meantime I have tried to run the example code for the acc. sensor. It does not work and shows up with an I2C error. This is probably what I should have expected with the WiPy being updated and the PyTrack operating still with the old firmware.

  • @buw there’s a timing issue to achieve the upgrade which is not necessarily obvious.

    What usually works for me is have the command ready in terminal, press and hold the button, plug in the USB port (on the computer, usually much easier), release button, wait 1 or 2 seconds, hit return. If it doesn’t work, try again.

Log in to reply

Pycom on Twitter