[Solved]: FiPy CAT M1 connection??

  • The code shown above works now, especially if you modem has the updated firmware. The issue I had was on the Verizon side...card activation and something to do with "Device needs to trigger OTASP to download the routable phone number via OTA". Which they fixed manually and now I am able to connect.

    Original post:
    I have two FiPy's one on Pytrack and another on Expansion Board 2.0.
    -Both Fipy's have the most updated firmware
    -Most updated modem firmware-
    -CTS/RTS jumper off Expansion 2.0
    -Tried 3 different LTE-CATM1 antennas
    -Drove 30 miles north/south of downtown Denver
    -My AT+CSQ on both are are between 10,99 and 16,99
    -My +CEER: lastEmmCause: NO CAUSE RECEIVED, lastEsmCause: NO CAUSE RECEIVED
    -Tried limiting the band to 13, as it was suggested that it should help.

    import socket
    import ssl
    import time
    from network import LTE
    import pycom 
    lte = LTE(carrier="verizon")    # instantiate the LTE object
    lte.attach(band=13)        # attach the cellular modem to a base station, initially it was lte.attach()
    print( " While loop1") # print stmt to check on terminal 
    time.sleep(5) # added 5 seconds wait
    pycom.rgbled(0x0000ff) # BLUE LED
    while not lte.isattached():
        print('Status:%s '%lte.send_at_cmd('AT+CEER'))
        time.sleep(5)  # originally 0.25 changed to 5.0
    lte.connect(cid=3)       # start a data session and obtain an IP address
    print( " While loop2")
    pycom.rgbled(0x00ff00) # GREEN LED
    while not lte.isconnected():
    s = socket.socket()
    s = ssl.wrap_socket(s)
    s.connect(socket.getaddrinfo('www.google.com', 443)[0][-1])
    s.send(b"GET / HTTP/1.0\r\n\r\n")
    print( " While end loop")
    pycom.rgbled(0xff0000) # RED LED, if it reached here we were successful

    Unit won't attach to network. Any suggestions?

  • @jmarcelino
    Thank you for all your help. We had provided Verizon the ICCID and IMEI 10 days ago at the time of provisioning request, but for some reason the IMEI was mixed up....and lost in translation. It was rectified over a troubleshooting ticket with Verizon.

  • For reference the problem was with Verizon provisioning they advised “Device needs to trigger OTASP to download the routable phone number via OTA”.

    After supplying the ICCID and IMEI Verizon solved the issue.

    Thanks @DDA for chasing the problem up with Verizon.

Pycom on Twitter