Seemingly impossible to connect in Pymakr with USB Expansion Board 3 + LoPy4 (Windows 10)

  • I'm a software developer and deal with annoying, wrong issue reports on my forum everyday. I can assure I did my homework and something is wrong.

    I am excited to begin using my LoPy4 + Exp Board 3 over the Pymakr/Atom REPL in Win10. Unfortunately this seems impossible.

    Short summary: Once I connect it over USB, I do not get any COM ports, only the "Expansion3" device in Device Manager (see screenshot). The Pycom Firmware Update (new ver 1.15) and Pymakr require a numbered COM port. When I take researched actions with the USB drivers to get a COM port, the firmware updater still categorically fails (screenshot below), and Pymakr doesn't recognize.


    Before you ask:
    -I am certain I'm using a 4-pole data USB cable, not just a charging one.
    -I did successfully install the expansion board firmware (distinct from LoPy firmware) with the instructions pertaining to the "dfu-util-0.9-win64" and "zadig-2.3.exe" downloads.
    -I am sure the module is oriented properly in board, with both visible "pycom" texts aligned.
    -LoPy does broadcast a WiFi network and we have the blue flashing LED as expected
    -I never messed with resetting by shorting GND/23 because I read you don't need to worry about that with Expansion Board 3.0
    -Yes, I read this post:

    Driver issues:
    -After following the instructions and not getting any numbered COM device, I tried installing the FTDI drivers here:
    -I then got a dysfunctional "COM11" to appear. It was there in Device Manager, but Pymakr wouldn't connect to it. And the Firmware Updater likewise failed:
    -I then tried to install the "pycom.inf" driver mentioned in the install instructions as the Windows 7 driver. Windows 10 wouldn't let me install it since it's not digitally signed.

    What is going on here? I have a typical Windows 10 setup and can't believe my experience with getting starting would be markedly different from anyone else's. But I can't get the most essential thing to work: the USB serial TTL connection to PC.

    My final application will need to have a USB connected LoPy spitting pulse data to my Windows 10 executable over USB, received over LoRa from my second LoPy module. This is critical for my use case of this ostensibly wonderful (though presently unusable) product. Thank you for your help.

  • @xykon Thank you so much for the help; I believe you've rightly pointed out my error was assuming the board firmware was installed correctly and only the device firmware was the problem.

    Hopefully this can be useful to others: what I seem to have missed is the distinction between the Bootloader mode and the Application mode. Once I got my successful command line result from "dfu-util-static.exe", I didn't think the text from an immediately proceeding sentence beginning with "If, by mistake, the" would apply to me, so I likely skimmed over the crucial sentence: "If, by mistake, the libusbk driver was installed while the USB ID is the Application mode (0xF013 for Pytrack or 0xF012 for Pysense), then the Serial USB (CDC) driver has to be installed for application mode. This will allow Windows to allocate a COM port, which is required for REPL console."

    I recommend that the help page 4.2.1 ( be rewritten to emphasize this point or at least put in a "Double-check Serial USB (CDC) driver is installed in Application mode" header right before the key sentence I missed.

    An additional element of confusion on that page is its direction regarding solely the "Pytrack/Pysense" boards, but it serves to document the steps for Expansion Board 3.0 firmware setup as well.

    Thanks again!

  • administrators

    @paulm It seems you accidentally installed the libusbk driver. Please follow the instructions in from If, by mistake, the libusbk driver was installed

Pycom on Twitter