Unable to use Rshell with Pybytes firmware

  • I know it isn't a PYCOM product, but many people in the community use rshell to connect quickly to PYCOM dev boards and transfer files.
    I recently started using Pybytes firmware on a LoPy and unfortunately Rshell is no longer able to connect.

    Has anyone else experienced this issue?

  • @jirkakrepl Thanks. I had worked this out.

  • @tuftec @philwilkinson
    Pymakr uploads all changed files at once. You cannot select which files to upload.

    But later e.g. when you change just single file, just this file will uploaded to board.

  • @tuftec, as I have not got a reply from Pycom, perhaps it is not possible!
    It seems the best (quickest) way to transfer a single file using the PyMakr plugin is to create a new folder and put your file in, then sync the folder to your connected Pycom board.
    The new file is added to the Pycom board and the existing files on the Pycom board are left alone

    Not ideal, but it works ok...
    Otherwise you have to keep changing the sync_folder and sync_file_types in the pymakr.conf file.

  • @philwilkinson I would also be interested in knowing how to transfer a single file.

  • Thanks for responding @jirkakrepl.

    I ran this yesterday using the Pycom Firmware Tool which presumably flashes the latest firmware on a Lopy1.0 and a Lopy4.0.
    Initially I used the Type: 'Pybytes' selection on the Pycom Firmware Tool.
    Serial communication was not possible on either board (using Rshell).
    I then reflashed both boards using Type:'stable' and I was able to connect fine (both boards).

    I also use Pymakr, and I agree that would be the best option.
    However, I wasn't aware I could transfer single files using the Atom PyMakr plug in, I thought the only option is to sync the entire folder you are working within in Atom.
    How do you do transfer a single file without messing around with the pymakr.conf file??


  • Hi,
    here at Pycom we are using Pymakr atom plugin to quickly transfer files.

    As far as I know, we even haven't tried to use rshell.

    Could you kindly test if rshell is still working on stable firmware?

    We've made some changes to pybytes firmware, so terminal in Pybytes can work. I am just guessing, but it could be why rshell is not working anymore with pybytes firmware.

Pycom on Twitter