TX/RX only console upgrade (Pymark) does not work with V1.9 firmware?



  • I designed lot of custom boards to handle lopy's for customers. On each board to be able to update and get control, I added a classic FTDI 6 pins connector.

    As you can see schematics below can't be simpler

    0_1535012098278_e389c153-8de1-4cca-8f9c-bd1963173009-image.png

    Everything is working fine, when on atom + pymakr can upload code without any problem with safe-boot or not activated.

    But this is working only for firmware 1.8 I tried several time to use with firmware 1.9 and I see my soft output on pymark console (the print I do on my code), but each time I'm trying an upload, it stuck, it reset the device then block, no file are updated or whatever and I need to reset the device with reset button.
    I tried with Lopy and Lopy4 same effect.

    Did I missed something ? It's really anoying because I need to stay in V1.8 since my devices are on field with customers. And not being able to update firmware remotely with them when doing tests is a real issue.

    Here are some screenshot of the issue with V1.19
    0_1535026414123_c6d29718-5d10-400d-9ed2-e2a27e98e5b3-image.png

    0_1535026428962_1df1473e-b54b-4bbb-b2a3-28824f5aa4c9-image.png

    And with version V1.8 all is fine
    0_1535026615663_b01dc76c-9dbb-4de7-9801-a2bc4f65e87e-image.png


  • administrators

    This issue is discussed on GitHub here


 

Pycom on Twitter