FTP access, device is seen but doesn't asnwer.



  • Hello, using Fipy with firmware 1.18.0.r connected with an Expansion board V2.1A and USB. I'm not sure if it's even possible to connect through FTP using Filezilla this way, but the documentation doesn't notify this at all.

    If I ping the device using it's standard IP address it does see it, but it doesn't answer, not sure if this is normal.

    Is there something that I'm doing wrong?


  • administrators

    @NickBoots , If you are connecting to an Access point from your pycom device (i.e Wifi in STA mode) disable the wifi on boot option via this command pycom.wifi_on_boot(False) reset board and try again.



  • @nickboots If you have a local access point, you can connect your FiPy to that. A sample script is here, section "Connecting to a Router"
    https://docs.pycom.io/tutorials/all/wlan
    The connection with your mobile may fail, if that ftp client cannot be set to the proper values, which are:

    • passive mode
    • singe session only

    The only mobile phone client I ever tried was FTP Client lite on IOS.



  • Trying to connect to it using my phone using AndFTP, as my PC has no WiFi. Can connect to the standard WiFi it has, but still no response when trying to access the FTP server.

    Edit: Also noticed the LED is not flashing blue, by the way...

    Edit 2: Resetted it, seems to flash blue again. No FTP possible yet, though.



  • How do I go about connecting this device to WLAN using ATOM to run Script on it? (As that seems to work, sometimes.)

    I try to follow the documentation, but honestly, to me it looks like a mess, constantly assuming things, checking if it works, but offering zero solutions in case of unexpected errors... :/



  • @nickboots The device should always be accessible via WiFi and FTP. The standard address is 192.168.4.1. In order to communicate to the device, you have to connect to it's Access Point. It then should respond to Ping. When uploading the firmware, ensure that it is configured to Wifi-on-boot True.


 

Pycom on Twitter