pycom wipy pysense problem

  • After some days of struggling I got pycom wipy with pysense board work perfectly – I could read all sensors and control the heartbeat LED.
    Next, I substituted the pysense with a pytrack board. One first problem was that it was very difficult to make atom understand that I now used COM8 instead of COM7.
    Next, after solving that issue, I was not able to transfer the file to the board so I could do nothing with it.
    And even much, much worse: When I returned to pysense I could not upload anything – except that atom started writing 3672 files and after 133 files (last one: ‘Writing file packages/pymakr/lib/python/ (12 kb)) declared:
    ‘Failed to write file, trying again.. Please reboot your device manually.’

    What can I do to get back to normal?

  • @dan I finally made it work! But only because of your advice! Thank you so much!!!

  • @priis Update the Pytrack firmware (steps here) and let me know if you still have this issue after the update

  • ... I tried the following with the pytrack board:

    from pytrack import Pytrack
    print('Pytrack imported')
    from L76GNSS import L76GNSS
    print('L76GNSS imported')
    import uos

    I got the following response:

    Pytrack imported
    L76GNSS imported
    (sysname='WiPy', nodename='WiPy', release='1.18.1.r1', version='v1.8.6-849-b0520f1 on 2018-08-29', machine='WiPy with ESP32')
    Traceback (most recent call last):
    File "<stdin>", line 7, in <module>
    File "/flash/lib/", line 8, in init
    File "/flash/lib/", line 176, in init
    ValueError: Firmware out of date

    How can I get rid of this error?

  • @priis What have you tried with the Pytrack? I don't think it's a hardware issue, it must be one of your settings. Can you make sure Pymakr is trying to connect to the correct port? (List serial ports then copy the correct one into address)

  • @dan I had .\atom open. I don't know how that happened and I didn't recognize that it could be a problem.
    Thank you for your help - now pysense works again after removing the .\atom folder.
    Have you any advice on how to make pytrack work? Should I buy another pycom wipy (esp32)? Or has it something to do with the settings of atom?

  • @priis Hi, which OS are you using? If you have a project settings file (pymakr.conf), the port in the address should be used. Did you have only the project you wanted to upload open?

Pycom on Twitter