Pycom Console not interactive on latest VSC/Pymakr



  • Still having difficulties in connecting and interacting with Pycom boards (1x FiPy, 2x LoPy on both Exp. board 2 and Pytrak). I can use a terminal (PuTTY/minicom) to access the REPL but inside Pycom Console (both Win10/64 and Ubuntu 18.10/64) I can't enter input mode, just output (seems to be read-only). Board version is 1.18.1.r1, VSC is 1.27.2 (node.js 8.9.3, embedded I think because installed version should be 10.10.0) and Pymakr is 1.0.3 (no other extension installed). Some commands work while other not. I can connect (serial) and see (just) the REPL output, run a script but not disconnect or enter e.g. ctrl/c to stop a running program. I also tried previous versions of VSC, still no success... Any idea? Thanks!



  • Hi @dan thanks for your reply. Actually not, also tried with an older VSC version (i.e. 1.25.1) but result is even worst (error: command pymakr.* not found and console doesn't start). Also downgraded Node.js to the LTS (8.12.0) but no luck. Because I'm using VSC for Python and to manage other non-pycom micropython-based boards via terminal it would be comfortable having a single IDE. Is there a particular setup known to work (firmware, VSC, Pymakr, Node.js, versions, platforms and architecture)?

    PS: Using Atom 1.31.1 on Win10/64 with Pymakr 1.4.4 I notice no issues, REPL responds correctly.


  • administrators

    @luca-gamma Hi, we're looking into your problem. In the meantime, have you tried using Atom?


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter