No gpy wifi AP on power up



  • My gpy no longer establishes an ad hoc wifi on powerup. Both main.py & boot.py are empty so something else in flash is permanently disabling the bootup AP.

    
    Pycom MicroPython 1.18.1.r4 [v1.8.6-849-dfa1176] on 2018-11-12; GPy with ESP32
    Type "help()" for more information.
    >>>
    >>> from network import WLAN; wlan=WLAN(); print(wlan.mode())
    1
    >>>
    

    the mode=1 tells me it's booting in STA mode, but it's not configured

    >>> wlan.ifconfig()
    ('0.0.0.0', '0.0.0.0', '0.0.0.0', '0.0.0.0')
    

    Presumably come config parameter in flash is responsible but I can't find any hint in the docs as to what it could be?



  • @kjm I just double checked this. Beware boys & girls. pycom.wifi_on_boot(0) not only permanently disables the power up ad hoc wifi it breaks the gpy FTP server so that it won't work on any wifi network you subsequently join.



  • Yea! That worked (once I removed the capitals). Interesting side bonus. The gpy FTP refused Filezilla connections in STA mode through my router once I lost the powerup ad hoc network, FTP now working again in both STA & AP modes. Can you tell me where in flash the pycom.wifi_on_boot(1) flag is stored? Is there a list in the docs somewhere of other flags that permanently alter the gpy? If so could you link me to it?



  • @kjm in your pymakr terminal try

    Import machine
    machine.reset()
    #once reset try
    Import pycom
    Pycom.wifi_on_boot(True)
    Import machine
    Machine.reset()
    

    If that doesn't work, I would suggest re flashing the firmware. Make sure you have the up-to-date firmware.


 

Pycom on Twitter