Atom foibles.



  • Experiencing a couple of Atom issues I can't seem to fix. Just wondering if anyone has encountered the same problems & has found solutions?

    1. If I'm editing code & click Run Atom sometimes runs the onscreen program, sometimes the saved version in the project folder on the PC & sometimes the saved version in flash on the gpy. This means I have to click save & upload after every edit to be sure all versions match which is a bit of a pain.

    2. If I lose the USB connection to the gpy then reconnect the Run button has mysteriously vanished so I have to close then reopen Atom to get it back again.



  • @kjm But maybe since we are mentioning it... someone who already has a fix can pass it along. Or someone who didn't realize it was a problem can make the next version a little bit better.

    Hopefully shared misery will have a shared cure. ;)



  • Shared misery then!



  • @kjm I have noticed the same things.

    #1 has forced me to remember to save first... which I think is good for me (knowing my work habits). But I don't need to upload, it will run the saved version (for me at least) without doing the upload.

    #2 Is a real pain. Sometimes doing a forced disconnect, then connect again clears it up, but not always. It becomes even more of a problem when I have multiple instances of Atom open attached to different boards. Once it happens it seems to cause other instances to behave the same way. Maybe it is a problem that effects a shared resource? So rather that waste time trying, I close them all down and reopen each which is a REAL PAIN since only one is "remembered" and the rest need to be browsed to so they can be reopened.


 

Pycom on Twitter