FiPy LTE not connecting after Upgrade Firmware

  • @akimmels I realized I should probably clarify this a bit.

    What this suggest to me is that when lte.attach()is called, the modem seems to reset itself, without lte.attach() returning or giving an error.
    So you think the modem is still trying to attach, but in fact it is reset....

    This can be seen from the CFUN returning 0 indicating that both RX adn TX of the modem are disabled. It can also be seen from the current the module is draining, which is much lower in the reset state than when the RX and TX are active.

    I flashed NB-IoT firmware (instead of LTE-M) into the modem, and was then able to attach and connect to a network and test connectivity. So this proves that the hardware is OK....

  • @steve-williams I have been trying a number of different options and combinations of GPY and Sequans firmware and I have not found a solution to the problems I am experiencing. While I strongly suspected the Sequans firmware, downgrading to 33080, then up to 38638 and 39529 showed no real difference to the problem I am having getting LTE to attach properly.

    With each Sequans version I tried Pycom GPY Release F/W GPy-1.18.1.r3, r4, r7 and also GPy-1.18.2. I also tried release candidates GPy-1.20.0.rc2, rc3, rc4 and rc7 - no joy with any of them or any combination.

    I had no difficulty with any of the firmware installs and my code doesn't seem to mind which version/s are running. But I still can't get LTE to attach. But I least I have gone through previous versions which did work OK previously.

    From here I can only try and prove that either the Sequans module itself (processor or radios) or perhaps the Expansion Bd. 3.0 is the cause. More testing to do now I have eliminated some possibles.

    Anyone else having trouble or lucked onto a solution?

  • My thought is that the Fipy Firmware is not the issue. but the Sequans firmware 39529 modem update was the issue. No problem running any Fipy Firmware old or new. Issues arise when using modem firmware 39529

  • I am wondering if I have a similar problem.

    Setup is FiPy on Pyscan module.
    FW version 1.18.2 and 39529 on the modem.
    When lte.attach() is called, and then quickly repeating AT+CFUN?, the modem first reports
    CFUN: 1. Shortly after it reports +SYSSTART and then CFUN: 0.
    As per Sequans AT manual, +SYSSTART is associated with modem reset/startup.
    Could this suggest that the modem reboots due to lte.attach() call?

    Below snap from terminal:

  • @paul-thornton Thanks for that advice, I will try that. However I am trying to deliver a finished prototype for team review, so I would prefer to use release version software really. Downgrade is perhaps an option at this stage - previous version worked fine for a long time!

  • @steve-williams a change in how the firmware handles things could cause more power usage. That said I'm not aware of anything specific that would have caused this.

    I'd suggest giving the latest rc firmware for the fipy a test. We've had a bunch of lte/stability improvements in the last few rc builds that could help.

  • I was having issues when trying to run the v18.1 code while attaching to Vodafone Aus. I upgraded to the latest dev version and a number of little issues just disappeared. I am now getting reliable connections every 10mins or so but every 2 - 4 hours my system crashes unexpectedly. No o/s errors reported. Just fall s back to the repl. No idea why yet.

  • @jordan-reyes That is my thinking too, but why start failing now, after working fine for months? No change to power supply etc.

  • @steve-williams my initial thoughts are it is not a network issue more along the lines of a power brown out, we did have a disconnection on the older firmware version, which we were testing on a power source that would have dropped below the recommended amps, although we did not have a monitor on it, that is what we thought.

  • @jordan-reyes OK, sounds similar then. I have added a VBatt monitor to my code and I note that when the LTE is trying to attach, that voltage reading drops from 4.2V (nominally 'normal') to 3.9 ~ 4.05 V like the modem is drawing a lot of power power? Still investigating that. I am in Australia so I was also wondering if some change has been made by Telstra on the network. I have tried several SIM's with the same result from the GPY.

  • @steve-williams it happened after upgrading to Sequans 39529.
    My only thought was to downgrade as well.

  • @jordan-reyes I have encountered a similar problem, my GPY worked for months OK but suddenly (happened while code was running) it will no longer attach to LTE consistently. I say consistently because every now and then it does work (once in several hundred attempts). I have tried changing antennas/cables without success - all the antennas have worked OK previously.

    This has happened since upgrading the GPY to 1.18.2. several days ago. Sequans firmware is 39529. Can I ask what firmware versions you are using?

    I am considering downgrading the firmware, but I am on a tight timeline at present. Does anyone have advice on how to trouble shoot this issue at the modem level?

Pycom on Twitter