FTP Upload and Sync Issue

  • First Issue:
    I included few non-python data files in my project. My main.py reads few things from that file. Then when I tried to sync my project from Atom's Pymakr plugin, that data file didn't upload. It seems like the plugin ignores anything other than the boot.py, main.py and the 3 folders. This rules are limiting my ability to work on realistic projects.

    Seond Issue:
    I use Cyberduck on my Mac to upload via FTP. I have been using it for many years successfully on many servers (i.e. VPS, Amazon, etc.) However, for some weird reason I am not able to upload any file to WiPy using Cyberduck. It only shows files and I can read/download them. If I want to upload something, I have to manually create them with Cyberduck (i.e. Create New Folder, then Create New File) and then instead of upload I had to use Edit then Save. Direct upload doesn't work.

    FYI: I also tried to upload from an iOS app I built for WiPy that only uploads a text file to WiPy. However, when I upload it, it actually creates a file with ZERO byte - the actual data disappear from it. I think this issue if related to the previous issue I mentioned above.

  • @reefat as documented here:

    There's a limit of 1 simultaneous connection, so you might have to tweak a few settings in Cyberduck or other FTP client. The described settings in FileZilla work very well.

Pycom on Twitter