2 of my LoPy Stop Working trying on the expansion board 2 and pysense



  • I dont understand why it stop working.... I have a expansion board 2 and pysense and problem is in both. This code is just a easy test to try upload the code.

    It stops working after a time i dont get it, I have latest firmware on lopy.

    Firmware:
    ---> atom 124.1 x64 (Only firmware that works)
    ---> pymakr 1.2.7 (Only firmware that works)

    0_1524650077801_dcf53fcf-08d0-4c50-aa2a-4a52b95c3bb0-image.png

    Still same thing.... Nothing happens...:

    0_1524727899967_ff85eb52-cc2d-400e-89f4-7d518dd45ec6-image.png


  • administrators

    hi @stefan85e,

    Short between G28 and 3V3 it's for safe-boot (booting without executing micropython scrips or loading previous OTA firmware). This is not required.

    Let's simplify and isolate problems.

    1. upload scripts with Atom
      Here make a simple print("hello") , no UART usage, yet; it should work

    2. usage of UART class.
      Here if you just want to output messages, print() method should be enough. UART 0 is already indirected to P0/P1, thru print(). The second UART (#1), it's for communicating with another device connected to the Expansion Board (not with the USB/FTDI chip).



  • @catalin also this is why I dont use latest version:

    I have connect 3.3V to G28 so I can upload code, for some reason it work from my win10 computer to upload code but i still dont understand what I should do to be able to use the uart..

    0_1524770376458_b3dea26f-2bb4-4e80-9bd0-bc528489bd43-image.png

    0_1524770421417_d87dfa8c-6ee3-41ac-a0fd-ff7c27954b9f-image.png

    0_1524770433311_38ef5ef4-e9b8-4bde-93eb-df140516e1fd-image.png

    0_1524770475072_b925f551-8f7b-4ab5-bdb1-3e7f16bfc02b-image.png



  • @catalin said in 2 of my LoPy Stop Working trying on the expansion board 2 and pysense:

    micropython

    When I trying this it stil dont work:

    0_1524770049520_83d402d9-1aee-4b08-b598-46b08005d06e-image.png



  • @catalin first it won't work with latest atom and pymakr I tried that like 10 times already I get error and can't upload anything... sadly...

    FTDI chip; the RX and TX are on P0 and P1...

    I tried use P0 and P1 but then I had problem that it did not upload so I tried change it that's why it has there :)

    from machine import UART

    uart = UART(1,baudrate= 9600, pins=('P0','P1'))
    print('Hello World')
    #uart.write('Hello')

    #uart.read(5)

    print(uart.any())

    Do you mean something like this!?

    http://www.ftdichip.com/FTDrivers.htm

    http://www.ftdichip.com/Support/Documents/AppNotes/AN_107_AdvancedDriverOptions_AN_000073.pdf


  • administrators

    Hi @stefan85e, why don't you update the Atom to 1.26.0, and Pymakr to 1.2.12, these seems to be the latest?

    Secondly, if you want to test a simple micropython script, use some simple print("Hello world!). Print uses UART0 which is connected to the Expansion board FTDI chip, and you can see the messages on USB.

    Thirdly, from your script, do you expect to see hello on Pymakr console? Your script defines UART1 on (P20-P23 pins), but these are not connected to the FTDI chip; the RX and TX are on P0 and P1. So you would need another FTDI chip interface connected to P20-P23 pins. Also, pay attention, that P20 is already used by UART0 RTS (and connected to FTDI_CTS). https://docs.pycom.io/chapter/datasheets/boards/expansion2.html


 

Pycom on Twitter