[SOLVED] /v2/register-sigfox returning response: "registerSigfoxDevice is missing some arguments"



  • I've been trying to register my device so that I can use SigFox. Tried registering using Pycom Firmware Updater, PyBytes app and also tried to provision the device via USB running the pybytes.activate()-function.

    I although keep getting following error message when entering the activation token that I have in PyBytes:

    pybytes.activate("{MY_SUPERLONG_ACTIVATION_GOES_HERE}")
    Disconnecting current connection!
    
    self.__connection_status=0 | self.__network_type=None
    
    Already disconnected
    {'a': '{ID}', 'p': '{WLAN_PWD}', 's': '{WLAN_SSID}'}
    performing Wi-Fi activation
    Please wait while we try to connect to {WLAN_SSID}
    WLAN connected? True
    Wifi connection established... activating device!
    
    Activation response:
    {'mqttServiceAddress': 'mqtt.pybytes.pycom.io', 'userId': '{USER_ID}', 'network_preferences': 'wifi', 'wifi': {'ssid': '{WIFI_SSID}', 'password': '{WIFI_PWD'}, 'deviceToken': '{DEVICE_TOKEN}'}
    sigfox_registration: {'activationToken': '{ACTIVATION_TOKEN}', 'wmac': b'{WMAC}', 'smac': b'{SMAC}'}
    
    
    /v2/register-sigfox returned response: registerSigfoxDevice is missing some arguments
    

    PS. {}-field have real values in the real response.

    The /v2/register-sigfox -endpoint, is that a Pybyte/Pycom endpoint or SigFox? And what other arguments are supposed to be supplied?

    My FiPy device is currently running '1.20.2.rc3' but I've tried the same procedure after flashing FiPy-1.20.2.rc6.tar with the same result. Pycom Firmware updater only works using "Flash from local file" due to the update failing and showing an error message saying "Could not connect to the board" using following settings:

    f9d7083c-d63d-4abb-8c4e-d070ab3feb23-image.png

    Result:

    d0ebb710-5f8f-444a-9f67-47709357956b-image.png



  • @jirkakrepl Got my FiPy working now. Thanks!



  • Now is working for me. I got a Sigfox ID and PAC



  • Hi, thanks for reporting this. We'll take a look



  • Exact same problem here with a FiPy


Log in to reply
 

Pycom on Twitter