Pymakr starts but generates errors on each user action - Mac OS X



  • Hello,

    Creating new issue since similar titles ("Pymakr does not start") were 4 months old.

    The first time I used Pymakr, it ran great and sent code to my LoPy perfectly, but now 8 hours later, it is reporting errors whenever I try to open a project, start a new project, etc. An example of the errors is pasted below.

    I am running Mac OS X and am used the Pymakr 1.0.0.b8 installer.

    Is there a fix for this?

    Also, is there an alternative IDE? I understand that Python scripts can be moved to LoPy using FTP, but... really?

    Thanks,
    Mike K


    2017-02-24, 14:34:43

    <type 'exceptions.AttributeError'>:
    'UserInterface' object has no attribute 'leftSidebar'

    File "/Applications/Pymakr.app/Contents/Resources/src/Plugins/PluginUpdate.py", line 133, in __onWindowLoad
    self.__ui.showEvent(event)
    File "/Applications/Pymakr.app/Contents/Resources/src/Plugins/PluginREPL.py", line 57, in __onWindowLoad
    self.__ui.showEvent(event)
    File "/Applications/Pymakr.app/Contents/Resources/src/Plugins/PluginPycomSync.py", line 73, in __windowLoaded
    self.__oldShowEvent(event)
    File "/Applications/Pymakr.app/Contents/Resources/src/Plugins/PluginPycomDevice.py", line 90, in __onWindowLoad
    self.__ui.showEvent(event)
    File "/Applications/Pymakr.app/Contents/Resources/src/Plugins/PluginFullUI.py", line 235, in __windowLoaded
    self.__setupSidebars()
    File "/Applications/Pymakr.app/Contents/Resources/src/Plugins/PluginFullUI.py", line 385, in __setupSidebars
    UiHelper.hideItemsSidebar(self.__ui.leftSidebar, toHideLeft)


    Version Numbers:
    Python 2.7.12
    Qt 4.8.7
    PyQt 4.11.4
    sip 4.18.1
    QScintilla 2.9.3
    WebKit 534.34
    Pymakr 1.0.0.b8

    Platform: darwin
    2.7.12 (default, Jun 29 2016, 12:52:38)
    [GCC 4.2.1 Compatible Apple LLVM 7.0.2 (clang-700.1.81)]

    Plugins Version Numbers:
    PluginAbout 6.1.0
    PluginAboutPymakr 1.0.0
    PluginCodeStyleChecker 6.1.0
    PluginCompletionJedi 1.0.3
    PluginEricapi 6.1.0
    PluginEricdoc 6.1.0
    PluginFeedback 1.0.0
    PluginFullUI 1.0.0
    PluginLiteUI 1.0.0
    PluginPycomDevice 1.0.0
    PluginPycomStyle 1.0.0
    PluginPycomSync 1.0.0
    PluginREPL 1.0.0
    PluginSyntaxChecker 6.1.0
    PluginTabnanny 6.1.0
    PluginUpdate 1.0.0
    PluginVcsMercurial 6.1.0
    PluginVcsPySvn 6.1.0
    PluginVcsSubversion 6.1.0
    PluginVmListspace 6.1.0
    PluginVmTabview 6.1.0
    PluginWizardE5MessageBox 6.1.0
    PluginWizardPyRegExp 6.1.0
    PluginWizardQColorDialog 6.1.0
    PluginWizardQFileDialog 6.1.0
    PluginWizardQFontDialog 6.1.0
    PluginWizardQInputDialog 6.1.0
    PluginWizardQMessageBox 6.1.0
    PluginWizardQRegExp 6.1.0
    PluginWizardQRegularExpression 6.1.0



  • @fos
    no its not
    it is discontinued only future plugin
    https://forum.pycom.io/topic/635/pymakr-time-of-death-09-02



  • Same problem with OS X. It worked but crashed after trying to increase font size. Tried deleting application, application files, and user files in home directory. Reinstalled with a new download. Same issue. Won't even start.

    Very buggy.

    I will try the windows version to see if it is any better.

    v/r
    fos



  • I've just got the same issue after brew upgrade if it makes sense...



  • @livius Thanks, I'm coming to the same conclusion. For as much as Pycom charges for their hardware, you'd think they could invest some of that money to produce a usable IDE.



  • @Mike-K
    Do not use Pymakr
    use any ftp client and work with it

    • some com port monitor


  • Also, I did try uninstalling then reinstalling Pymakr, but encountered the same issue.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.